Maven Web Proyects en Eclipse 3.7 Indigo

Si lo haces a mano segun el tutorial Maven Web Proyects en Eclipse 3.7 Indigo, solo falta un detalle, agregar el runtime de Tomcat: Java Build Path > Libraries > Add Library > Server Runtime > Tomcat 7.x

Y si te aparece el error:

Dynamic Web Module 3.0 requires Java 1.6 or newer. […] Maven WTP Configuration Problem
One or more constraints have not been satisfied.

Hay que tocar el pom.xml

<project>
	<build>
		<plugins>
			<plugin>
				<groupId>org.apache.maven.plugins</groupId>
				<artifactId>maven-compiler-plugin</artifactId>
				<version>3.1</version>
				<configuration>
					<source>1.6</source>
					<target>1.6</target>
				</configuration>
			</plugin>
		</plugins>
	</build>
</project>

Si lo haces con el plugin m2eclipse-wtp (Window > Preferences > Maven > Discovery). Para Juno m2e-wtp (Eclipse Market place).

Referencias:
http://sosiouxme.wordpress.com/2012/05/21/470/
http://stackoverflow.com/questions/6356421/maven-tomcat-projects-in-eclipse-indigo-3-7
http://stackoverflow.com/questions/6656622/deploy-project-to-tomcat-from-eclipse
http://www.lintips.com/?q=node/140

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: